On Sun, Nov 12, 2006 at 11:09:33PM -0500, MichaelL_at_frogware.com wrote:
> Change the "for" import syntax in libraries to make it easier to read.
>
> Replace
>
> (for <import set> <import phase> ...)
> (import r6rs (for (add-prefix (my-helpers id-stuff) mh-id:) expand))
>
> with
>
> (for <import phase> ... <import set>)
> (import r6rs (for expand (add-prefix (my-helpers id-stuff) mh-id:)))
+1
> The underlying implementation may or may not be marginally more
> difficult, but if it is I think the effort is worth the trade-off.
Agreed.
> Anoher variant on this idea is:
>
> (for <import phases> <import set>)
>
> Where <import phases> (note the plural) is:
>
> <import phase>
> (<import phase> ...)
I get the impression that importing for multiple phases is far less
frequent than importing for all phases or one phase, so I prefer
(for <import phase> ... <import set>)
over
(for (<import phase> ...) <import set>)
--
Trent Buck, Student Errant
Received on Mon Nov 13 2006 - 12:10:04 UTC