--- This message is a formal comment which was submitted to formal-comment_at_r6rs.org, following the requirements described at: http://www.r6rs.org/process.html --- name: Kent Dybvig email: dyb_at_cs.indiana.edu type: defect priority: minor component: arithmetic version: 5.92 Summary: ->exact and ->inexact should be renamed Description: These names ->exact and ->inexact are ugly. They also vaguely imply a conversion is necessarily occuring and, therefore, that ->whatever should not be applied to something that is already whatever. (They are, however, better in this regard than the original names inexact->exact and exact->inexact.) Proposal: Change the name ->exact to exact and change the name ->inexact to inexact, so that, e.g., (exact 3.0) and (exact 3) are both 3 and (inexact 3.0) and (inexact 3) are both 3.0. These names appear more or less like casts and do not imply that a conversion is necessarily taking place. They are also consistent with the names char-upcase, string-downcase, etc., which contain no -> and also name procedures that operate on values that may need no conversion. To my mind, they also seem more consistent with the #e and #i exactness prefixes.Received on Sun Mar 04 2007 - 23:56:37 UTC
This archive was generated by hypermail 2.3.0 : Wed Oct 23 2024 - 09:15:01 UTC